Jump to content

Recommended Posts

G'day fellas. I started a brew last night (MR IPA) and it detected start of fermentation today. I opened it up a few minutes ago to add some hop pellets in a infuser ball and it seemed that all of the ingredients were stuck on top of the water and there was an inch thick hard layer. I busted it up with a sterilised spoon and added the hops but my question is, has anyone opened their droid this early and is this hard layer normal this early on? I just expected all ingredients to dissolve pretty quickly

Share this post


Link to post
Share on other sites

Never opened up and had a look.

Maybe contact BrewArt and ask the question.

After 24 hours I would expect the heavier ingredients to have mixed, well at least not formed a pavement on the top.

 

Share this post


Link to post
Share on other sites

I reckon it would have supported a small child's weight haha. It just did a fermentation test and it all seems to be going ok so who knows 

Share this post


Link to post
Share on other sites

You got me thinking.

I have just started a Ruby Porter, 22 hours ago.

So at the risk of contaminating it, I had a look.

And a pic.

 

IMG_2947.JPG

Share this post


Link to post
Share on other sites

That makes me feel better. Cheers for that mate, I have never opened mine up until mid way through fermentation to add hops etc but got in a little early this time. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...