Jump to content

Unable to get the brew Flo to pressure- E3 error


Recommended Posts

2 hours ago, Luke Sibenaler said:

Hi,

I am unable to get the brew Flo unit to work?

it continues to bring up the E3 error code?

any tips or tricks to rectify would be appreciated.

I have tried with keg not attached and still the same error.

Regards,

Luke.

 

Have you taken the elbow off the air pressure hose?

Are you 100% certain the lid is closed on the brewflo?

If you have the elbow on the pressure hose, carefully take the keg out for a min and tighten the black lug, if it is tight at hand turn, get some pliers (not tin snips, you make that mistake only once...or twice in my case...OK, it was three times*) and give it another half turn, then carefully put it back in and connect the hoses and see if that works

Let us know

 

*Obviously, I didn't do that 3 times with tin snips

 

It was four times

 

  • Haha 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...